小小風 發問時間: 教育與參考考試 · 1 0 年前

問一個cisco的指令?

請問一下,下面這個指令是什麼意思?

它下在3550的L3 Switch上

switchport trunk allowed vlan 2,31,1002-1005

已更新項目:

它的interfacse 共設了下列的指令

switchport access vlan 16

switchport trunk allowed vlan 2,31,1002-1005

switchport mode access

no ip address

spanning-tree portfast

3 個解答

評分
  • 睡仙
    Lv 4
    1 0 年前
    最佳解答

    switchport access vlan 16 -->把這個port設定給VLAN16使用

    switchport trunk allowed vlan 2,31,1002-1005 -->把這個port設定成trunk,並且只允許VLAN2、31及1002-1005的封包可以通過

    (這兩行指令矛盾了,PORT只能設成ACCESS或TRUNK其中一種)

    switchport mode access -->把這個port設定成access模式

    no ip address -->這個port不設ip(如果設ip上去就成了svi了)

    spanning-tree portfast -->這個port的stp設定快速收斂(這又是一個矛盾,會設定成藥做stp的port不是都沒設定mode(因為要和switch連接),要不就是設成trunk)

    2006-03-18 18:16:45 補充:

    switchport trunk allowed vlan 2,31,1002-1005 -->把這個port設定成trunk,並且只允許VLAN2、31及1002-1005的封包可以通過在說的仔細一點,就是這個trunk只帶2、31、1002-1005VLAN ID 的TAG

  • CCIE
    Lv 4
    1 0 年前

    您的config有些問題吧,

    switchport mode 不是access就是trunk.

    而您在interface vlan16之中也沒有可以下trunk allowed吧且把spanning-tree關了..

    您在下這些command應該有message吧.

    %Warning: portfast should only be enabled on ports connected to a single

    host. Connecting hubs, concentrators, switches, bridges, etc... to this

    interface when portfast is enabled, can cause temporary bridging loops.

    Use with CAUTION

    %Portfast has been configured on FastEthernet0/15 but will only

    have effect when the interface is in a non-trunking mode.

    標準的config應該沒有這樣做的.

    參考資料: 自己
  • 1 0 年前

    1.在switch interface 下的指令

    2.讓這個interface變成trunk 允許vlan2,31,1002-1005 使用這個interface

還有問題?馬上發問,尋求解答。