Yahoo奇摩知識+將於 2021 年 5 月 4 日 (美國東部時間) 終止服務。自 2021 年 4 月 20 日 (美國東部時間) 起,Yahoo奇摩知識+服務將會轉為唯讀模式。其他Yahoo奇摩產品與服務或您的Yahoo奇摩帳號都不會受影響。如需關於Yahoo奇摩知識+ 停止服務以及下載您個人資料的資訊,請參閱說明網頁。

發問時間: 電腦與網際網路軟體 · 1 0 年前

電腦裡的Microsoft .NET Framework

電腦裡的Microsoft .NET Framework

我看到好多版本

1.0

2.0

3.0

這些是要幹麻的???

一定要全部都有嗎???

要是沒這個會怎樣呢???

2 個解答

評分
  • ?
    Lv 7
    1 0 年前
    最佳解答

    你好:從微軟官網所摘錄有關Microsoft .NET Framework資訊如下:

    Microsoft .NET Framework可轉散發套件包含了執行以.NET Framework開發的應用程式所需的一切項目。 .NET

    Framework 版提供改進的延展性和效能、支援使用 ASP.NET Mobile 控制項 (先前稱為 Microsoft Mobile

    Internet Toolkit) 的行動裝置開發、支援 Internet Protocol Version 6 以及與開放式資料庫連接

    (Open Database Connectivity,ODBC) 和 Oracle 資料庫進行原生通訊的 ADO.NET

    類別;也可以利用程式碼存取安全性進一步鎖定和隔離 ASP.NET應用程式。

    相信以上這些資訊並非太多人會明白,簡單的來講有許多網路連接軟體(例如大家都經常都在使用的MSN,有些經過網友所改進的版本都是使用.NET Framework所開發出來),這樣就需要安裝.NET Framework才可以使用。除了MSN之外另外還有許多有關資料庫遠程通訊和傳送的軟體也會使用到.NET Framework;它的版本確實很多,除了你提到的1.0, 2.0, 3.0之外,其中還包括有1.1, 1.1sp, 3.5, 3.5sp等版本,這些是否需要全部都有呢?如果你的電腦之中己經安裝有以上所提到的任何版本,答案是需要的,建議你繼續保留.不然有可能需要用到的時候就無法開啟軟體了,主要原因是Microsoft .NET

    Framwork並不會像其他軟體那樣新的版本可以兼容舊的版本,例如Microsoft .NET Framwork 3.5sp就不會向下兼容2.0的版本,同樣2.0的版本也不兼容1.1或是1.0的版本,一但有某一套軟體需要Microsoft .NET Framwork2.0,雖然你有保留Microsoft

    .NET Framwork 3.0,但移除了Microsoft .NET Framwork2.0之後仍然是無法使用的;除非你已經很清楚你的電腦己經不再需要某個版本才去移除。

    2010-04-09 20:11:10 補充:

    如果想了解多一些,你也可以參考一下意見區的賤狗大師的意見,以及參觀一下賤狗大師的部落格,裡面除了有講解我所提到的MSN所需的.NET Framework問題之外,賤狗大師也是一位資深的電腦專家,在他的部落格之中你還可以知道非常多有關電腦的防毒防駭知識以及一些電腦軟體的教學和小常識,個人覺得非常值得去參觀一下。

  • 匿名使用者
    1 0 年前

    這些是要幹麻的???

    答:簡單說就是安全程式

    一定要全部都有嗎???

    答:最好全部都有

    要是沒這個會怎樣呢???

    答:【可能】某些程式會需要這些安全元件,一旦沒有就可能無法執行。

    舉個例子;下面的程式就需要Microsoft .NET Framework 2.0以上的版本,若沒有會無法執行該程式。

    http://tw.myblog.yahoo.com/1314-5257/article?mid=5...

還有問題?馬上發問,尋求解答。