匿名使用者
匿名使用者 發問時間: 電腦與網際網路程式設計 · 9 年前

IIS安裝PHP

我用的是筆電

內建作業系統是w7家用進階版

最近想學PHP

剛好手邊有一本dreamweaver+PHP+mysql

前面有各apache的套件

但是裝在W7似乎無法啟動

於是改用後面註解方式

裝載IIS後想用擴充模組ISAPI

下載PHP5.3居然沒有ISAPI選項

改用PHP5.2就有該選項

裝載後都無法啟動PHP

顯示結果為HTTP 錯誤 404.17 - Not Found要求的內容似乎是指令碼,因此靜態檔案處理常式便不會對它進行處理。

想請教一下,怎麼處理

或是怎樣才能在W˙7下裝載三合一的APACHE+PHP+MYSQL

2 個解答

評分
  • 9 年前
    最佳解答

    我跟您一樣的毛病

    查到您的發問

    本來還贊助又加入追蹤

    希望能有人回答並及早解決

    但我東查西查

    有看到某英文網頁上的說明

    發現要開IIS管理員

    找到[應用程式集區]

    選[進階設定]

    把[啟用32位元應用程式]

    由False改為True

    就解決囉

  • Sam
    Lv 6
    9 年前

    下載及安裝「wamp」套件。

    最好選用支援64bit(如果你是win7 64bit)

    任何有建議你安裝appserv請全部忽視。

    因為appserv已經很舊很舊。

    另外你那本書丟掉吧。

    重新去買一本php專門學習的書籍。

    並且建議不要使用dreamweaver寫php,否則日後問題會非常多。

還有問題?馬上發問,尋求解答。