icmp ping 廣播位置問題

我想請問以下在命令提示字元下:ping 192.168.1.1 對方主機會回應。

想說如果ping 192.168.1.255 廣播位置應該會回應的!!

但經過在網路上查詢相關討論,

在"windows"環境下是不回應廣播位置的icmp封包,linux則會回應。

我實際測試結果,windows下大部分是不回應的,

但有成功過一次會回應來自多來主機的reply封包,

想請問為什麼大部分不回應?但有時對方卻會回應?

※電腦與區域網路環境無做任何改變。

2 個解答

評分
  • 9 年前
    最佳解答

    這是主機防火牆的設定

    若是妳把MS Windows防火牆disable, it will reply to ping to subnet broadcast address too.

    但是要小心smurf attack

    2012-03-05 23:04:50 補充:

    在ubuntu 或是其他linux之中 the following file

    /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts

    若是設定為

    1=no response to ICMP to broadcast address

    0=response to ICMP to broadcast address

    2012-03-05 23:07:46 補充:

    I am sure MS Windows will have a registry you can set to allow ICMP reply to broadcast but I have no interest in MS windows at all, so you need to find it out yourself.

    2012-03-06 07:02:55 補充:

    For MS Windows - see the following on how to block/enable the response:

    To block unicast responses to multicast traffic Open the Group Policy Object Editor snap-in to edit the Group Policy object (GPO) that is used to manage Windows Firewall settings in your organization. Open Computer Configuration, open Administrative Templates, open Network, open Network Connections, and then click Windows Firewall. In the details pane, double-click Windows Firewall: Prohibit unicast response to multicast or broadcast requests. In the Windows Firewall: Prohibit unicast response to multicast or broadcast requests properties dialog box, on the Settings tab, click Enabled. Notes To open a command prompt, click Start, point to All programs, point to Accessories, and then click Command Prompt.

    Windows Firewall is not included in the original release of the Windows Server 2003 operating systems.

  • 9 年前

    防火牆開和關都測試過了,不會回應...

    其實我就是要測試smurf攻擊,哈哈~

還有問題?馬上發問,尋求解答。